TLS 1.0 Support Ending

We’re writing today to let you know that we’re going to be discontinuing support for the old TLS 1.0 protocol as of October 22, 2019.

We’ll continue to support the newer and more secure TLS 1.1 and TLS 1.2 protocols. ┬áTLS 1.0 requires the use of older cipher suites and poses a security risk, so we will no longer allow it to be used for ExaVault connections.

TLS 1.0 has already been deprecated by most web browsers that connect to ExaVault, including Chrome, IE, Firefox and Safari. Most FTP software already uses TLS 1.1 or higher when making FTPS connections. Therefore, we expect this to be a transparent change for nearly all of our users. But if you have legacy software that you are using to connect to ExaVault, or if you are forcing TLS 1.0 connections, you should update your configuration within the next two weeks.

If you have any questions regarding this upcoming change, please reach out to us at support@exavault.com.

Thanks,

The ExaVault Support Team